"klassischer Kipper" ignoriert Zusatzscripte

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    "klassischer Kipper" ignoriert Zusatzscripte

    Hallo zusammen,

    ich wollte in meinem Spielstand eigentlich den klassischen Kipper (Drehschemel, seit gestern auf Modhub) verwenden, und da noch die dynamic Hoses :love: einbauen, weil ohne einfach nicht mehr geht. Das habe ich schon mehrfach bei anderen Fahrzeugen gemacht, bin in der Hinsicht also kein Laie.

    Jedoch scheint der konsolengeeignete Kipper das Script zu ignorieren, im Spiel sind die ab- und angebauten Schläuche sichtbar, lassen sich nicht ankuppeln und das Licht geht auch ohne angebaute Schläuche.

    Schon probiert habe ich: Zip umbenennen, neuer Vehicle-Typ, neue Moddesc, Indexe der Schläuche mehrfach überprüft, aber immer wieder ignoriert der Kipper das Zusatzscript der dynamischen Schläuche, vermutlich um konsolengeeignet zu bleiben.

    log ist komplett fehlerfrei, was den Kipper betrifft, der verwendete Traktor hat natürlich seine entsprechenden Anschlüsse, beim Spenderanhänger (Krone Vario 1500) funktionieren die Schläuche auch.

    Also: Wie verklicker ich dem Hänger, das er nicht mehr konsolenfähig sein muss und Zusatzscripte zulässt, da ich ihn nur privat auf PC verwenden will / werde? Der Hänger ist Modell und Texturtechnisch ein echter Hammer :thumbup: , aber ohne Dynamic Hoses geht da gar nix. :thumbdown:

    Auszug Moddesc


    <specializations>
    <specialization name="dynamicHose"className="DynamicHose" filename="DynamicHose.lua"/>
    </specializations>

    <vehicleTypes>
    <type name="Old_Tipper" className="Vehicle" filename="$dataS/scripts/vehicles/Vehicle.lua">
    <specialization name="attacherJoints" />
    <specialization name="lights" />
    <specialization name="attachable" />
    <specialization name="animatedVehicle" />
    <specialization name="cylindered" />
    <specialization name="foldable" />
    <specialization name="tensionBelts" />
    <specialization name="washable" />
    <specialization name="mountable" />
    <specialization name="dynamicHose" />
    </type>
    </vehicleTypes>




    Auszug 6 Tonner xml

    <!-- dynamicHose -->
    <dynamicHose>
    <set toolIndices="0">
    <hose type="hydraulic" attached="2>2|0|1|0|1" detached="2>2|0|1|1|0" lastHoseIKNode="2>2|0|1|0|0|0|0" />
    <hose type="electric" attached="2>2|0|1|0|2" detached="2>2|0|1|1|1" lastHoseIKNode="2>2|0|1|0|0|0|1" />
    </set>
    </dynamicHose>



    Für Hilfe wäre ich sehr dankbar, ich würde den Hänger echt gerne verwenden.

    Gruß
    Ich habe mir das Teil mal angeschaut, du meinst doch den Krone Emsland umbau oder?

    Wenn es der ist musst du noch mehr Einträge machen

    Spoiler anzeigen


    Moddesc:

    <vehicleTypes>
    <type name="Old_Tipper" className="Vehicle" filename="$dataS/scripts/vehicles/Vehicle.lua">
    <specialization name="attacherJoints" />
    <specialization name="lights" />
    <specialization name="attachable" />
    <specialization name="animatedVehicle" />
    <specialization name="cylindered" />
    <specialization name="foldable" />
    <specialization name="tensionBelts" />
    <specialization name="washable" />
    <specialization name="mountable" />
    <specialization name="dynamicHose" />
    </type>
    </vehicleTypes>

    <vehicleTypes>
    <type name="Old_Tipper1" className="Vehicle" filename="$dataS/scripts/vehicles/Vehicle.lua">
    <specialization name="attacherJoints" />
    <specialization name="lights" />
    <specialization name="attachable" />
    <specialization name="animatedVehicle" />
    <specialization name="cylindered" />
    <specialization name="foldable" />
    <specialization name="tensionBelts" />
    <specialization name="washable" />
    <specialization name="mountable" />
    <specialization name="dynamicHose" />
    </type>
    </vehicleTypes>

    Und das in der Xml:

    Den Eintrag <vehicle type="trailer"> abändern das es so aussieht <vehicle type="">

    Dann musst du aber jetzt noch diese Einträge ab Zeile 61 (was in rot ist) abändern:

    <vehicleTypeConfigurations>
    <vehicleTypeConfiguration name="$l10n_configuration_bigTrailer" price="50" vehicleType="trailer"> (den Eintrag in Old_Tipper ändern)
    <objectChange node="0>1|0|0|0|1|0|0" visibilityActive="true" visibilityInactive="false"/>
    <objectChange node="0>1|0|0|0|1|0|1" visibilityActive="true" visibilityInactive="false"/>
    <objectChange node="0>1|0|0|0|1|0|2" visibilityActive="true" visibilityInactive="false"/>
    <objectChange node="0>1|0|0|0|2|2" visibilityActive="false" visibilityInactive="true"/>
    <objectChange node="0>1|0|0|0|3|2" visibilityActive="false" visibilityInactive="true"/>
    <objectChange node="0>1|0|0|0|0|1" visibilityActive="true" visibilityInactive="false"/>
    <objectChange node="0>1|0|0|0|1|0" visibilityActive="true" visibilityInactive="false"/>
    <objectChange node="0>1|0|0|0|7" visibilityActive="true" visibilityInactive="false"/>
    <objectChange node="0>1|0|0|0|4" visibilityActive="true" visibilityInactive="false"/>
    <objectChange node="0>1|0|0|0|1|0|0|0" collisionActive="true" />
    <objectChange node="0>1|0|0|0|1|0|1|0" collisionActive="true" />
    </vehicleTypeConfiguration>
    <vehicleTypeConfiguration name="$l10n_configuration_BaleTrailerMD" price="50" vehicleType="nonameBaleTrailer"> (den Eintrag in Old_Tipper1 ändern)
    <objectChange node="0>1|0|0|0|2|2" visibilityActive="true" visibilityInactive="false"/>
    <objectChange node="0>1|0|0|0|3|2" visibilityActive="true" visibilityInactive="false"/>
    <objectChange node="0>1|0|0|0|7" visibilityActive="false" visibilityInactive="true"/>
    <objectChange node="0>1|0|0|0|0|1" visibilityActive="true" visibilityInactive="false"/>
    <objectChange node="0>1|0|0|0|1|0" visibilityActive="true" visibilityInactive="false"/>
    <objectChange node="0>1|0|0|0|1|0|0" visibilityActive="false" visibilityInactive="true"/>
    <objectChange node="0>1|0|0|0|1|0|1" visibilityActive="false" visibilityInactive="true"/>
    <objectChange node="0>1|0|0|0|1|0|2" visibilityActive="false" visibilityInactive="true"/>
    <objectChange node="0>1|0|0|0|4" visibilityActive="false" visibilityInactive="true"/>
    <objectChange node="0>1|0|0|0|1|0|0|0" collisionActive="false" />
    <objectChange node="0>1|0|0|0|1|0|1|0" collisionActive="false" />
    <!--<objectChange node="0>1|0|0|0|1|0|0|0" translationActive="0.873 -0.977 0" translationInActive="0.032 -0.118 0" />
    <objectChange node="0>1|0|0|0|1|0|1|0" translationActive="-0.942 -0.98 0" translationInActive="-0.028 -0.116 0" />-->
    <size width="3.5" />
    </vehicleTypeConfiguration>
    </vehicleTypeConfigurations>



    sag bescheid ob es jetzt funktioniert!

    Gruss Werner
    Ach DA wird nochmal der vehicle Typ erst / nochmal definiert. Ok, again what learned. Ich habe für den Kipper jetzt einen Vehicle Typ vom normalen "trailer" mit dynamic Hoses, und für den Ballenwagen den normalen vehicle Typ mit dynamic Hoses angelegt und eingetragen. Vielen lieben Dank für den Hinweis. Jetzt läuft die Sache. :thumbsup: